virtual virtual unreality

ok i’m learning how to use QEMU this morning. i’d like to get a PPC OSX running, maybe fuck around with Haiku and the latest Fedora or Ubuntu. i’m running off Win10 and just trying to figure out how to invoke the qemu commands. should i just get a gui?

1 Like

i should have learned this forever ago but windows path/cmd stuff just baffles me still. every time i think i figure out how to be able to address windows applications from the command line i realize i’m still confused

much later edit: ok yeah find the system properties > advanced > environment variables > path > edit > new > add directories you want to be available from cmd or powershell

i’m extremely tempted to spin up some linux flavor on my old HP 2000 notebook which runs win10 direly but presumably will beast out on some lightwight distro assuming i can at least have wifi drivers and shit

maybe i should make a thread for this but shouldn’t it be possible, nay trivial to put all my qemu tools in my windows path so i don’t have to manually navigate to the qemu dir just to be able to run qemu-img and boot my image

edit: god damn virtualization is the most fun you can have with a computer isn’t it

edit 2: ok so i created my drive image, got fedora to boot and all, but i think i need to give my vm more memory and shit because it appears to crash before initializing anything after i try to launch the installation media. but i do get the fedora installation media to boot now! gotta look up the right arguments to feed it. maybe all it needs is more memory

FUCK YES WE ARE BOOTING

3 Likes

I scrolled too fast and I thought you were being asked to mount a Facebook iso or something

4 Likes

i’m still trying to get it running well. why is qemu only using a single thread by default!?!?

i guess that could be considered sensible. do i need to enable some shit in my bios, god damn it

edit: ok i enabled windows hypervisor and installed haxm, that’s gotta be sufficient right

edit: this is partly wrong, see several posts down for more accurate instructions

i forgot how fun/infuriating stuff like this is, it’s really enjoyable to a certain part of my brain

if anyone is following along at home, i needed to:

  • get a copy of some operating system installation media (fedora.iso in my case)
  • install qemu
  • install haxm
  • run cmd.exe

cd path\to\qemu

then

qemu-img create fedora.img 10G

qemu-system-x86_64 fedora.iso -drive format=raw,file=fedora.img -accel hax

which might be a regression because i was previously also explicitly giving it 4 gigs of memory… hmph. i can boot back into the fedora livemedia but when i press start it seems to not want to progress to the initialization part

i went back to the drawing board in the first place because without acceleration fedora was too slow to even use, the mouse wouldn’t go where i pointed it

look i get it, i get it, i understand why everyone uses virtualization management tools with a gui even in linux lol, this shit is a fucking nightmare

hmm after a restart i can no longer pass the argument -accel hax it just gives me an error that it failed to open the HAX device and failed to get hax capability:6u :frowning:

ok ok ok i think i needed to also enable windows features hyper-v

ok nope i still don’t know why hax worked once and then stopped working after a reboot :frowning:

wait wait ok this needs to be disabled

ok all further updates on hold until i rtfm. i would love to have a dedicated vm thread tho, would be cool

okie dokie lol
image
hacker voice we are in?

image
hacker voice we are too much of a chongus

holy shit qcow performance without a cache or pre-allocation is slow as dogshit :frowning:
learning lots of things

I haven’t used qemu on native x86 platforms ever really, only to get x86 on arm, so I have no idea whether it can just use regular virtualization for x86 on x86 at this point, but regardless there are definitely better windows cli options you could be using when you do need to do something natively

i’m not sure i follow this - also can we possibly split this whole diatribe to a vm thread? that might be fruitful because this is something i really enjoy learning about and fiddling with

what do you mean about better windows command line options? you mean i shouldn’t bother booting into linux in a vm or whatever? i guess i don’t necessarily have any functional need to do so, i’m just trying to learn more about virtualization

yeah I will split this later on

1 Like

This past week, inspired by @loki’s & @meauxdal’s posts about that PPC Mac emulator, I tried running the PPC build of this PPC Mac emulator on my PPC Mac. It accepted all the files and whatever, but then beachball’d and crash’d after confirming everything. Very well.

Decided to do some more looking into if other people had gotten OS9 to install on this/other unsupported PPC machines. Turns out that is, in fact, a thing, and there is a patched OS 9 install that purports to run on every G4 machine.

Found it, got it, Restored it to a USB drive, tried to boot it. Didn’t work. Turns out most PPC machines can’t boot from USB, but some can but then only USB1 equipped machines not later USB2 machines? Fuzzy. Fine, I will burn it to optical media.

Found a spool of blanks in my computer parts junk bin, pop one in. Turns out they are DVD+R and the eMac reads DVD but only writes CD-R. The only other optical computer drive I have in this house is a slot-loading DVD-RAM cart/disk drive. Fine. 10pk CD-R for $3.99 with Next Day Prime Shipping. They arrive, I burn the image, smacking my lips and rubbing my hands. Now I will play physical Playstation discs in Connectix Virtual Game Station, and life will be good.

Nope, doesn’t work, doesn’t even see the install disc in the boot loader thing. After further sleuthing, seems like some fellers got their eMacs working by spoofing the processor ID with some terminal-based NVRAM hack string stuff, and some others similar stuff using the Open Firmware prompt. Some of this does nothing for me, but one method takes - and blammo now we can see the install disc in the boot loader. Click. Hangs on the disk-icon “?” screen.

Further reading, seems like most/all of the people that have managed to get a later eMac running have the 1.25ghz, and maybe it’s the fact there isn’t a proper driver for the Radeon 9600 in the 1.42ghz eMac, but others say this shouldn’t be a dealbreaker, and one singular guy on the whole web seems to say his 1.42ghz is working, yadda yadda yadda: let’s call it a day.

5 Likes

Computers!

3 Likes

i think i’ll try out haikuOS next, it seems pretty cool
i want to run OSX but that one seems a little tricky so i’m working up to it

ok so let me go over what i did, correctly this time, to get QEMU running accelerated on win10 64bit

  • get a copy of some operating system installation media (fedora.iso in my case)
  • install qemu
  • confirm that both windows hypervisor platform and hyper-v are disabled in windows features, or you may run into errors when installing haxm
  • install haxm
  • optionally: start > systempropertiesadvanced.exe > environment variables… > select Path entry > edit… > new > paste in path\to\qemu
  • open powershell and navigate to the qemu folder (you can skip this if you added it to the path environment but you’ll need to specify full filepaths for the images and isos i think):

cd path\to\qemu

  • still in powershell, use the qemu image tool to create a 20 GB raw image to serve as virtual hard drive:

qemu-img create -f raw f2.img 20G

  • now it’s time to spin up the actual VM and install fedora. use the appropriate architecture for your install media, turn on hardware acceleration to improve performance, and give it 8 GB of memory (possibly overkill for what i’m doing):

qemu-system-x86_64 fedora.iso -drive format=raw,file=f2.img -accel hax -m 8G

  • install your OS of choice to the hard drive, then power off and:

qemu-system-x86_64 f2.img -accel hax -m 8G

to get going for real

running a computer inside a computer? this is literally the most fun you can have with a computer

2 Likes

OK win95 was a little more challenging because it needs way more arguments to work right
to make the hard drive:

qemu-img create -f raw 95.img 2G

to install windows (boot from floppy, run fdisk, enable large disk support, reboot, format c, then install win95 by running setup.exe from the cd-rom)

qemu-system-i386 -netdev user,id=mynet0 -device ne2k_isa,netdev=mynet0 -hda 95.img -m 64 -cpu pentium -vga cirrus -boot a -fda disk01.img -cdrom Win95.iso

to run win95 after install

qemu-system-i386 -netdev user,id=mynet0 -device ne2k_isa,netdev=mynet0 -hda 95.img -m 64 -cpu pentium -vga cirrus -boot c

this one kept erroring out when i tried to pass arguments that were recommended in the documentation e.g. -soundhw sb16 -localtime -soundhw pcspk

also i could absolutely not get qemu to use a qcow format image as the hard disk for win95. it would throw an error unless it was raw. this doesn’t bother me too much as i had performance issues with qcow - i guess maybe it works better on ext4/linux?

result has been worth it thus far at least, though i expect PCem might provide better performance; no idea

wow getting osx 10.5 or 10.6 working on qemu from windows seems like hard mode because qemu doesn’t support dvds

on linux apparently you can just grab the more recent installers directly from apple

One of my hopeful goals for this weekend from way earlier in the week was to install xp through hyper-v so I can play with old minidisc software. And now I’m halfway there!